Azure Container Instance Error for Windows Containers

Last week, I was trying to deploy an ASP.NET Core application to Microsoft Azure Container Instance (ACI) and received the following error.

Error Message

The Windows version of image ‘deploy.azurecr.io/password:latest’ is not supported. The supported Windows versions are: ‘10.0.14393

When I viewed the detailed deployment log, I found that ACR only supports Windows Server 2016 images.

When I reviewed the images used in my app they were on Nano Server 1803 release which is not supported on ACI.

Change Images to Long Term Channel Release

After reviewing Microsoft documentation, I found that I need to use the Windows Server 2016 Nano Server image and not the ones that are part of the Sami-Annual channel release as shown below:

mcr.microsoft.com/dotnet/core/runtime:2.2-nanoserver-sac2016
mcr.microsoft.com/dotnet/core/sdk:2.2-nanoserver-sac2016

 Recommendation

It is important to note that these images are not supported by Microsoft anymore and I recommend you move your .NET Core application to Linux Containers which are fully supported on Azure ACI.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.